XCode 4.3 - Build error “missing required architecture armv7”

0 votes
78 views
asked Jan 1, 2013 in xCode by john (4,220 points)

After upgrade XCode from 4.2 to 4.3 I've got below problem. I can't build it. Do you guys have idea how can I resolve this problem? even some clue would be helpful to me.

1 Answer

0 votes
answered Jan 1, 2013 by sahana (2,250 points)

What fixed it for me was:-

  1. Select Project in project navigator
  2. Select Test Target
  3. Select Build Settings
  4. Go down to Framework Search Paths and single-click it
  5. Delete whatever is there
  6. Enter $(SDKROOT)/Developer/Library/Frameworks $(DEVELOPER_LIBRARY_DIR)/Frameworks
  7. If you had any custom frameworks, add those back

 

...